Quick note, and it’s not too hard, but took a few minutes to remember.

Amazon Linux comes with Java 1.7.0 installed. I wanted to upgrade to 1.8.0 for Elasticsearch 5.3

 

Awesome!

 

Not Awesome

Just yank out 1.7.0

If you need both installed, maybe an old piece of code needs 1.7.0 and all your other stuff can deal with a global default of 1.8.0,   update your legacy apps to specify the JAVA_HOME environment variables to the real location of java-1.7.0, and update the global system like this:

Had I not removed Java 1.7 already, I’d have 1.7 and 1.8 in that list to choose from.

 

 

Short URL: http://bit.ly/2o8tKzM